Heartbleed bug

Heartbleed

There’s been quite a lot of buzz in the last few days regarding the Heartbleed bug. It’s an exploit in OpenSSL, a software library used to secure the communication using SSL, potentially exposing secure web pages.

I’d like to inform that this website is immune to the exploit. The OpenSSL version used to secure the browsing isn’t affected by the Heartbleed bug.

Account details were not exposed and there is no need to change your password or any additional action.

Leave a Reply